Products
Webtrends Analytics 8.0x
Issue
Geotrends is installed and enabled either globally or on a per-profile basis, web logs contain client IP information and data displays in the “Countries” report, but the “Cities and States” report show no data.
Cause
The format for the cities and states fields in the Geotrends database changed with the release of Webtrends Analytics 8.1, and as a result, the use of more recent versions of the Geotrends database will not provide full compatibility with Webtrends Analytics 8.0d and earlier.
Resolution
The only compatible GeoTrends.dat file is the 11/2006 release, available for direct download from the following URL:
http://webtrends.cnc.net/GeoTrends/Download/GeoTrends.8.200611.dat
After the download has completed, install the GeoTrends.dat file using the steps below.
1. Stop the scheduler and GeoTrends services on the Webtrends server in the following order:
“Webtrends – Scheduler Agent”
“Webtrends – GeoTrends Server”
2. Navigate to the following location:
\WebTrends\modules\Geotrends
3. Rename “geotrends.dat” to “geotrends.old” then copy GeoTrends.8.200611.dat to the folder and rename it to geotrends.dat.
4. Restart the services in the opposite order.
On the next analysis, profiles will display geographical information for the new report data. To populate the historic data in reports that experienced issues with the incompatible version of GeoTrends, reanalyze the profile.