dcsimg

A product update alert states that a lookup data update is available, even though the 9.2b update is already installed.

Products

Webtrends Analytics 9.2b

Issue

In the Active Alerts section of Webtrends On Premise, the following Product Update alert keeps popping up stating that an update is available for lookup data:

“A Product Update is available! Config Data version 9.2b is available from the following url: http://product.webtrends.com/lookupdata/payload/default.aspx?version=9.2b&os=win32

When the update is downloaded attempted to install, the installer states the update is already applied and no installation is required. Yet, the alert above keeps occurring.

Cause

This is caused by the Version entry in thewtmaster.dbo.wt_componentlist not updating to 9.2b for lookup data.

Resolution

To correct this, verify that the entry has not been updated by running the following SQL query:

select Tag,version from wtmaster.dbo.wt_componentlist where tag = ‘lookupdata’;

It should come back as “lookupdata” under the Tag column and a value other than 9.2b under the Version column. If it does, run the following query to update:

update wtmaster.dbo.wt_ComponentList Set Version=’9.2b’ where Tag=’lookupdata’;

This will update the version for lookup data to be 9.2b. Once complete, acknowledge the alert in the Analytics UI and from this point forward product update alerts for lookup data should only occur when there is an update beyond 9.2b.