dcsimg

What is the difference between a stalled scheduler and a stalled scheduled job?

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Issue

Webtrends returns alerts stating that the scheduler has stalled or that a scheduled job has stalled. Examples of these messages are displayed below, as well as the reason why they appear.

Resolution

Stalled scheduler alert message:
The scheduler has stalled. It has been more than 8 hours since a task has started. For more information about how Webtrends responds to this problem, see Alert Configuration in the Help. For information about resolving the problem, see Resolving Alert Conditions in the Help.

Cause:
The scheduler has stalled. This message states that a job hasn’t run on the scheduler agent in the last 8 hours. If profiles are only set to run once a day and they all complete within the first few hours, you will likely see this message

Stalled job alert message:
A Scheduled Job has stalled. Job Description: [Name/Process]. It has been more than 16 hours since this job has run. Webtrends will attempt to continue to schedule other jobs. For more information about how Webtrends responds to this problem, see Alert Configuration in the Help. For information about resolving the problem, see Resolving Alert Conditions in the Help.

Cause:
A Scheduled Job has stalled. This is similar to the first message, but may require attention. It could possibly mean that other jobs are taking too long to process and that the queue is backed up and this job will not be able to run until the others have completed. It can also mean that it runs only once a day, thereby creating a sixteen-hour gap between analysis.

Solution:
If jobs are completing as expected every day, and they have the current report data then click the Acknowledge or Defer buttons to remove the alerts from the Active Alert listing. These messages are not necessarily indications of failure, only that there may be issues preventing or delaying scheduled jobs from completing on time. If it is the case that jobs are not completing please contact Webtrends Technical Support for assistance in troubleshooting this issue.