dcsimg

The SDC does not generate log files and displays errors Incorrect usage… another file is already open and Exceeded an internal buffer size.

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Issue

The SmartSource Data Collector (SDC) stops logging and errors similar to the following appear in the dcs.audit log file:

Feb-19-2009 08:51:25: ####
Incorrect usage: Attempted to open file: d:\logs\dcs\dcs000089_xxxx-dcs-2009-02-19-08-00202-wtssdc102.dcsbusy. Another file is already open: d:\logs\dcs\dcs000089_xxxx-dcs-2009-02-19-08-00202-wtssdc102.dcsbusy
Current Method: lfmLogRecord::WriteLogRecord
Source Method : lfmBaseFile::Open()
Source File : ./src/lfmbasefile.cpp
Source Line : 547

or

Mar-27-2009 08:28:58: ####
Exceeded an internal buffer size
Current Method: lfmCookieHelper::CreateMap()
Source Method : lfmQuickString::Resize()
Source File : ./src/lfmquickstring.cpp
Source Line : 118

Cause

This is a problem where a large cookie results in a buffer error in the SDC and causes it to cease functioning. Restarting the machine will temporarily address the issue but for a permanent solution, the affected dll must be replaced.

Resolution

Attached to this article is a replacment iislogserver.dll

Steps for replacement are as follows:

1. Stop IIS
2. Replace the file in the following location
Webtrends\Smartsource Data Collector\bin
3. Restart IIS