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Rsync changes permissions when copying log files from Unix/Linux machines running under Cygwin

Products

Webtrends On Premises 9.x
Webtrends On Premises 8.x

Issue

When attempting analysis of log files retrieved from Unix- or Linux-based machines running under Cygwin, analysis fails and displays one of the following error messages:

Could not extract \\servername\path\logfilename.log.gz: disk full?

Error: Profile cannot analyze unless all servers have a valid logfile path or the IgnoreMissingServerLogfiles ini key is set to true.

It has been confirmed that sufficient drive space is available on the target drive and that compressed archives can be extracted and analyzed manually without issue.

Cause

The former error message will, in default configurations, result from a lack of drive space, and both the former and latter error messages may also result from failure to assign the needed permissions to the Webtrends service account which it would use to access the files on the local drive. If it can be confirmed that the correct permissions had been previously been assigned, yet these same errors persist, it may be due to the process which moves log files to the Webtrends server removing permissions on the files or folder(s) as they are copied.

Resolution

The temporary solution is to reassign permissions on the folder and files that have been affected. The long-term solution is to ensure the process affecting permissions is either configured to avoid this from happening, or an intermediary process automates reassignment of permissions to prevent obstruction of analysis.