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Report Exporter installer opening when the application is already installed

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Issue

When attempting to run an export within the Webtrends user interface, the installer for the Report Exporter continues to appear even though the Report Exporter is already installed. This issue is sometimes displayed as an error stating the Report Exporter installed is the incorrect version when the version checked within the Add or Remove Software dialogue shows the correct version is indeed installed.

Cause

This results from the registry entry the Report Exporter application references having either missing or incorrect information.

Resolution

Add the correct registry key for your version of Webtrends. There are two registry keys that are necessary for Java to read to allow the Report Exporter to run successfully. They can be found in the following path:

HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Prefs\com\webtrends\docutil\rde and
HKEY_CURRENT_USER\Software\JavaSoft\Prefs\com\webtrends\docutil\rde

The former will have a pointer to the directory in which the Report Exporter is installed, and by default it is set to C:\Program Files\Webtrends Report Exporter. If the Report Exporter is installed elsewhere, this will need to be edited.

Once the .reg files have been downloaded, one may simply double-click on the file to add it to the registry. After this has been done, clear the browser cache and attempt the export again. If Java is properly installed, it should go through successfully.

To ensure you are downloading the correct version of the registry key, please check the version of your Report Exporter:

1. Go to Start > Settings > Control Panel > Add or Remove Programs.

2. Select the entry for Webtrends Report Exporter and click on the “Click here for support information” link. The version number will display.

3. Download the attached zip file and select the current_user_rde.r_g file and the add_rde_[version].r_g files that match the version of Report Exporter on the machine having issues.

4. Extract the needed files and rename both file extensions to .reg, then double-click each one to run the keys.

Note: There is only one registry file for the HKEY_CURRENT_USER listing, as it is not version-specific.