dcsimg

No report data available after upgrading

Products

Webtrends Analytics 9.x

Issue

After upgrading, when you try to view reports for a profile, you see an error message similar to: “No reports available”. This may effect every profile in your install, or just a few. Profiles may analyze successfully as well.

Cause

This behavior has been traced to an improper entry in the customtables/default.ini file. In particular, a report attached to the profile contains an invalid dimensionXdata entry (where X is 0 or 1). In one instance the following data was found (bad entry):

dimension0data = w4NxtDTxi06
dimension0excludenonestrings = false
dimension0guid = w4NxtDTxi06

Resolution

Simply clicking Edit, and then saving theprofile without making changes rewrites the entry. In the case of the above example, the corrected entry looked like:

dimension0data = hitpropertydimension
dimension0excludenonestrings = false
dimension0guid = w4NxtDTxi06

Note: Your corrected entry may be different than the above example.

After re-saving the report, you should be able to access report data on your profile unless there was another custom report present on that profile with an invalid entry.

If the broken report entry was on a global profile, this condition will prevent all profiles from loading report data. Simply editing and saving all of the user created custom reports corrects the issue here as well.