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Multiple IP addresses appear in the cs-client field in the web log files

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Issue

Multiple IP addresses appear in the cs-client field of the web log files, causing entries to be omitted or analysis to fail with the message, “An error occurred. No valid records found in log file.”

Cause

This issue is caused by a load balancer appending addresses to the true client’s IP address. The appended addresses are usually the address of the load balancer or any other device that may have passed the request.

Resolution

To resolve this issue, configure the load balancer to not append addresses to that header. Refer to your particular hardware’s installation and configuration documentation for help setting up your load balancer.