Products
Webtrends Analytics 9.x
Webtrends Analytics 8.x
Issue
Your Smartsource Data Collector (SDC) is generating multiple dcsbusy files, possibly all having the same DCSID in the filename and just different timestamps.
Cause
This can be caused by antivirus scans or protection locking the dcsbusy files. In particular this was noticed on SDC 9.2 with McAfee software.
Resolution
Disabling the antivirus or excluding the SDC folders from scanning and protection, and then rebooting the server corrects this issue in this case.
If the above solution does not rectify the issue then the cause may be related to the permissions assigned to the identity that owns the .dcsbusy files. If you right click on a .dcsbusy file and select properties and then click on the “Details” you will see the “Owner” this is the user that owns the file. The default identity is the “Applicationpoolidentity”. If this identity lacks sufficient rights it may be necessary to change ownership to a user that has the proper permissions i.e. Read, Write and Execute.
To change the ownership of the dcs.busy files access the server manager and expand the “Roles”, under “Roles” expand “Web Server (IIS)” and then highlight “Internet Information Services (IIS) Manager”, next select “Application Pools” and then highlight “SDC Application Pools”. In the right hand margin click on “Advance settings” then scroll down to “Process Model / Identity” from here you can set the “Identity” to a user with the appropriate permissions.
After making this change restart IIS at this point you should see all the .dcsbusy files convert to “.log” files with the exception of the new .dcsbusy files to which it is currently writing.