dcsimg

Job or jobs running for a long period of time and preventing other jobs from running

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Issue

When analyzing a large amount of past data, the same analysis job or jobs are showing in the Job Queue for a long period of time. This stops other profiles from entering the queue.

Cause

This occurs when the profile’s Analysis Throttling is set to “Rerun analysis immediately after maximum amount of data is analyzed”. The profile will keep running in the queue until it is all caught up. This means other profiles will not get a chance to run.

Resolution

To resolve this, you can do one of two things.

A) Cancel the current running job and disable the profile until the other profiles, that have more current data, finish analyzing.

B) Disable the rerun analysis setting which will allow it to analyze up to the analysis throttling limit and then go to the bottom of the job queue to be ran again. To do this edit the profile by going to Reports & Profiles > Hover over the profile(s) in question > Select Action > Edit.
Next, navigate to Analysis > Analysis throttling and uncheck the box for “Rerun analysis immediately after maximum amount of data is analyzed”. Lastly, cancel the current running job.