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Installation of Webtrends hangs when installing the “Main Application and UI Server”

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Issue

When the install attempts to install the “Main Application and UI Server”, the install hangs for quite a long time and will eventually fail with the error:

Error installing component: Main application and UI Server
Error code: 259

Cause

This is usually caused by one of the following:

  • The firewall doesn’t allow contact to the outside world, but the DNS servers are resolving “license.webtrends.com”. When the installation can resolve “license.webtrends.com”, but nothing is returned, the installation will keep trying the servers assuming that there’s just a delay with the licensing servers. Eventually it will time out and throw the error.
  • When trying to contact the licensing servers, https is not being allowed. The install will also continue to try and eventually time out.?
  • The password being used contains quotation marks ” or ‘

Resolution

For the DNS servers, remove the DNS servers from the TCP/IP stack during installation. This is found in your network card properties. Create an empty file named “noprodlicclientssl” in the following folder: \WebTrends\common\lib

This will then force the product to use standard http instead of the secure protocol for all communications with the licensing server.

Once the product is installed, go through the following steps.
  1. Reboot
  2. License the product
  3. Add back in the DNS servers to the to the network adapator
  4. Reboot again and you should be able to log in.

If the password contains quotation marks, change the password to use another character or characters besides these.