dcsimg

“HTTP Error 404.8 – Not Found” after install/upgrade to Webtrends Analytics 9.x

Products

Webtrends Analytics 9.x

Issue

After a Webtrends Analytics 9.2a upgrade or fresh installation, opening Webtrends generates a “HTTP Error 404.8 – Not Found”. In the “Requested URL” portion of the error it shows “http://<servername>/wrc/bin/WebTrendsReportingCenter”. The physical path points to \Webtrends\common\jakarta-tomcat\bin\WebTrendsReportingCenter

Cause

This is caused by one or two (or both) specific IIS settings in the “WebTrends Marketing Lab” web site. Both settings are specific to the “bin” application in the “wrc” virtual directory.

Resolution

The first is Request Filtering. Open the wrc virtual directory and highlight the “bin” application. Under “IIS” in the details pane on the right, double-click the “Request Filtering” icon and select the “Hidden Segments” tab. If there is a segment named “bin”, remove this segment.

The second setting is in “Handler Mappings”. Click on the “bin” application again and double-click the “Handler Mappings” icon. All of the DLLs should be set to the “Enabled” state. If they are not, right-click on any of the names in the list and select the “Edit Feature Permissions” option. In the “Edit Feature Permissions” dialogue box, make sure all three options are selected (Read, Script, and Execute) and click OK. IIS and the web site should not need to be restarted. Just refresh the screen showing the 404.8 error and the login screen should appear.