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Cannot delete custom report because it’s “In use by system”

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Issue

When you try to delete a custom report, it may say “In use by system – for more information, contact your administrator” in the Show Uses section.

Cause

This is because the custom report was attached to a profile that is pending deletion. The user will be able to delete the custom report once the profile has been deleted.

Resolution

To avoid this message, make sure the custom report is detached from the profile before deleting the profile.

In some case you may have to manually remove a custom report by editing the profile’s WLP file the report is tied to. First you need to find the Internal ID of the custom report by editing the report and going to the Summary tab. You will see this line:
Internal ID: QWdRX0XxNH6

Then edit the profile you want to remove the custom report from and go to the summary tab. You will see a line like this:
Profile File Name: fFenlh8XDH6

The go into the storage\config\wtm_wtx\datfiles\profiles directory and find a file that matches the profile file name and ends in the .wlp extension. Example:
fFenlh8XDH6.wlp

Search for the Custom Report Internal ID. You will find it on the following line:
includecustomtableprofiles =

Delete the internal ID and save the wlp file.