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Attempting to manually export with Webtrends Report Exporter returns message: Error. Click for details

Products

Webtrends Analytics 9.x

Issue

After installing or upgrading to version 9.x, the following error message displays when trying to perform a manual export using Webtrends Report Exporter:

“Error. Click for details”

Cause

This happens due to the permissions of the user account used for the Webtrends\wrc Virtual Directory within IIS. By default, IIS will use the standard IUSR account for authentication when connecting to the webtrends\wrc\component virtual directory. Often, this user account does not have proper permissions (adminprivileges) to access the necessary directory for Report Exporter (\storage\config\component).

Resolution

This can be resolved in two ways:
1. Give the directory full access to the IUSR account:
a. On the Webtrends server, navigate to the following location:

\Webtrends\storage\config\

b. Right click on the config directory, choose “Properties.”

c. Click on the “Security” tab and click “Edit.”

d. Click on “Add”, type in IUSR, then click on “Check Names.” This will populate the IUSR account to the left.

e. Click “OK”, then “Apply.”

f. Restart the Webtrends IIS website and log out of the current session and log back in for this to take effect.

2. Change the user account used by the virtual directory.
a. Open IIS, expand the Webtrends website, expand the wrc virtual directory, click on the “component” virtual directory.

b. Click on “Authentication”, highlight “Anonymous Authentication” and choose “Edit…” on the right.

c. Change the user account to use “Application Pool Identity” and click “OK”.

d.Restart the Webtrends IIS website and log out of the current session and log back in for this to take effect.

The article titled “Report Exporter fails to export, displays red X with java.io.IOException and/or Downloader_Applet not found errors” may also apply to this error.