dcsimg

A profile’s status messages state “Task Execution has failed” when it has completed successfully

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Issue

When analysis of a profile begins, on reaching the “Tasks currently running” queue in the Scheduler, the profile immediately fails and displays the message “Task execution has failed.”

Cause

Under “Web Analysis > Reports and Profiles,” clicking on the “Task execution has failed” error message displays detailed information. The “Status from job sub-tasks” displays messages indicating the profile analysis progressed beyond the time of the reported failure, and that it completed successfully.

In the example below, the job failed at 11:16:50 based on the status messages in the “Status from job” section. However, under “Status from job sub-tasks” the job has updates after 11:16:50, and has analyzed a number of records and pushed the data back to be visible for viewing.

Status from job
4/26/10 11:16:50 AM Task execution has failed.
4/26/10 11:16:50 AM Processing on host01.
4/26/10 11:16:50 AM Task queued for execution on host host01.
4/26/10 11:16:40 AM Queued for processing.
4/26/10 11:16:40 AM Started.

Status from job sub-tasks
4/26/10 11:17:09 AM ==================== ANALYZEPROFILE.VBS FINISHED ====================
4/26/10 11:17:09 AM =============== Analysis Sync Utility Finished ===============
4/26/10 11:17:09 AM Performing maintenance on local profile data.
4/26/10 11:17:09 AM Finished push of FastTrends database to Analysis Data Repository
4/26/10 11:17:09 AM Started push of FastTrends database to Analysis Data Repository
4/26/10 11:17:09 AM Finished zip of local FastTrends databases
4/26/10 11:17:08 AM Started zip of local FastTrends databases
4/26/10 11:17:08 AM Finished push of on demand report database to Report Data Repository
4/26/10 11:17:08 AM Started push of on demand report database to Report Data Repository
4/26/10 11:17:08 AM Finished push of status logs to Analysis Data Repository
4/26/10 11:17:08 AM Started push of status logs to Analysis Data Repository
4/26/10 11:17:08 AM =============== Analysis Sync Utility Started ===============
4/26/10 11:17:08 AM Running… ASU – Pushing local data
4/26/10 11:17:08 AM Running… Visitor History – Count
4/26/10 11:17:07 AM lADTQCWnjk6 total time was 0:00:14 (14 seconds).
4/26/10 11:17:07 AM lADTQCWnjk6 analysis time was 0:00:08 (8 seconds).
4/26/10 11:17:07 AM Max memory usage (physical/virtual): accumulation: 163 / 241 MB, merge: 161 / 242 MB, report gen: 165 / 246 MB.
4/26/10 11:17:01 AM lADTQCWnjk6 parsing complete: 4832 records processed.
4/26/10 11:16:53 AM Processing records from Fri Apr 02 01:00:33 2010 to Sat Apr 03 00:59:44 2010.
4/26/10 11:16:53 AM Processing log files for profile: test (Copy) (lADTQCWnjk6).
4/26/10 11:16:53 AM 1 member(s) remain to be analyzed:
4/26/10 11:16:53 AM 1 member(s) found in log list.
4/26/10 11:16:53 AM Reverse DNS enabled.
4/26/10 11:16:53 AM =-=-=-= Initializing profile =-=-=-=
4/26/10 11:16:51 AM Running… WTRS
4/26/10 11:16:51 AM =============== Analysis Sync Utility Finished ===============
4/26/10 11:16:51 AM Finished pull of FastTrends database to local machine
4/26/10 11:16:51 AM Started pull of FastTrends database to local machine
4/26/10 11:16:51 AM Finished pull of status logs to local machine
4/26/10 11:16:51 AM Started pull of status logs to local machine
4/26/10 11:16:51 AM Performing maintenance on local profile data.
4/26/10 11:16:51 AM =============== Analysis Sync Utility Started ===============
4/26/10 11:16:51 AM Running… ASU – Pulling remote data
4/26/10 11:16:51 AM Profile has been reset.
4/26/10 11:16:51 AM Backup Utility is finished.
4/26/10 11:16:51 AM WRC Profile lADTQCWnjk6 has been reset
4/26/10 11:16:51 AM Beginning reset of profile 2, account 1
4/26/10 11:16:51 AM Backup Utility is in “Reset_Profile” mode using ProfileID=2
4/26/10 11:16:51 AM Backup Utility is starting.
4/26/10 11:16:50 AM Profile ID: 2 WRC Profile ID: lADTQCWnjk6

Resolution

To display consistency in status messages and the application output, the “Debug Programs” local security policy must be granted to the service account under which Webtrends’ services are running. This policy can also be assigned to the “Administrators” group, of which the service account should be a member.

1. On the Webtrends server, open the Services snap-in and confirm the name of the service account under which the Webtrends services are running.

2. Navigate to “Administrative Tools > Local Policies > User Rights Assignment.”

3. Right-click on “Debug Programs” and select “Properties.” The Debug programs Properties dialog box displays.

4. Assign the account or group to the policy and click “Apply” to save the change.

5. Restart the “Webtrends – Scheduler Agent” service.


Further information:
KB MS SQL 2008 fails to install states error Access Denied– MS SQL 2008 fails to install, states error “Access Denied”