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Custom Report Filters appear to have no effect

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Cause

You have created a custom filter for a custom report. However, after applying the filter, there is no change in the data after re-analysis.

Resolution

For a custom filter to work, it must affect or refer directly to either the measures or the dimensions of the report. For instance, a hit based filter must be able to reference an individual line from which the dimension data was derived.

Example:
Pages is a hit based dimension, so if I have a include hit filter based on a query parameter passed by a particular page, it will affect the list of pages in the dimension.
However, Visit Duration is a visit based dimension. So a custom report hit filter will not affect the list of visit durations, although it can influence the Hits measure. This is also true ofPage Views in Visit.
A simple way of remembering this is that both Visit Duration and Page Views in Visit are things that could only be known after the visit session has been assembled as data, whereas Content Group can be known per line in the log file.