dcsimg

How to troubleshoot and install the Data Scheduler Service manually if it fails during an upgrade

Products

Webtrends Analytics 9.2

Cause

During an upgrade of Webtrends the following error displays while the Data Scheduler service installs:

Error 1001

Resolution

When the error occurs, hit “OK” to proceed with the upgrade. The Data Scheduler service will not install, but the entries for it will be in the database.

Navigate to the following directory:

\Webtrends\modules\Webtrends.DataSchedulerService\

Open the following file in a text editor:

Webtrends.DataSchedulerService.InstallLog

This log will explain why the Data Scheduler did not install successfully. It may often be due to the following error:

System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 – No connection could be made because the target machine actively refused it.)

To resolve this particular issue, modify the wt_databaseinstance table and install the Webtrends Data Scheduler service manually.

Modifying the wt_databaseinstancetable:

1. Navigate and open/edit the wtmaster.wt_databaseinstance table.

2. The two columns in this table that are usually the cause of this are: InstanceName and Port. The port is most often set incorrectly to 3306 and the InstanceName is set toNULL.In 9.2x, if SQL Express is being used, the InstanceName should be set to WTSYSTEMDB and the port should be set toNULL. You may either change these manually or by running the following update statement:

UPDATE wt_DatabaseInstance
SET InstanceName=’WTSYSTEMDB’,Port=NULL
WHERE DatabaseInstanceID=1;

Note: If the machine name is incorrect in this table, manually change it to the correct name.

Installing the Data Scheduler service manually:

1. Navigate to the following file in the customer’s installation and open it

\Webtrends\logs\install\setup.log

Locate the line similar to the following:

Installing Data Scheduler Service: C:\Windows\SysWOW64\msiexec.exe /i “C:\Users\wtservice\AppData\Local\Temp\2\Webtrends_9.2.1.290\msi\Webtrends Data Scheduler Service.msi” /qb! /l*v “D:\Program Files (x86)\Webtrends\logs\install\Data Scheduler Service 12-13-2010 18-05-07.log” INSTALLDIR=”D:\Program Files (x86)\Webtrends” STANDALONE=”false” MASTER_HOST=”MACHINENAME” MASTER_INSTANCE=”WTSYSTEMDB” MASTER_PORT=”” CACHE_ENABLED=”false” CACHE_PROVIDER=”Memcached” CACHE_NAME=”DX2″ CACHE_HOSTS=”” SERVICEACCT=****** SERVICEPASS=****** IGNORE_SYSTEMCHECK=TRUE REBOOT=ReallySuppress

2. Copy and paste everything after “Installing Data Scheduler Service:” into a text edit. You should now have copied into the notepad the following:

C:\Windows\SysWOW64\msiexec.exe /i “C:\Users\wtservice\AppData\Local\Temp\2\Webtrends_9.2.1.290\msi\Webtrends Data Scheduler Service.msi” /qb! /l*v “D:\Program Files (x86)\Webtrends\logs\install\Data Scheduler Service 12-13-2010 18-05-07.log” INSTALLDIR=”D:\Program Files (x86)\Webtrends” STANDALONE=”false” MASTER_HOST=”MACHINENAME” MASTER_INSTANCE=”WTSYSTEMDB” MASTER_PORT=”” CACHE_ENABLED=”false” CACHE_PROVIDER=”Memcached” CACHE_NAME=”DX2″ CACHE_HOSTS=”” SERVICEACCT=****** SERVICEPASS=****** IGNORE_SYSTEMCHECK=TRUE REBOOT=ReallySuppress

Update the SERVICEACCT and SERVICEPASS with the domain\username and password of the user account being used. When complete, the entry should appear as follows:

Example:

SERVICEACCT=webtrends\username SERVICEPASS=Password1

3. Open a command window and paste the installation command, with the updated user name and password, as shown in the example below:

C:\Windows\SysWOW64\msiexec.exe /i “C:\Users\wtservice\AppData\Local\Temp\2\Webtrends_9.2.1.290\msi\Webtrends Data Scheduler Service.msi” /qb! /l*v “D:\Program Files (x86)\Webtrends\logs\install\Data Scheduler Service 12-13-2010 18-05-07.log” INSTALLDIR=”D:\Program Files (x86)\Webtrends” STANDALONE=”false” MASTER_HOST=”MACHINENAME” MASTER_INSTANCE=”WTSYSTEMDB” MASTER_PORT=”” CACHE_ENABLED=”false” CACHE_PROVIDER=”Memcached” CACHE_NAME=”DX2″ CACHE_HOSTS=””SERVICEACCT=webtrends\username SERVICEPASS=Password1 IGNORE_SYSTEMCHECK=TRUE REBOOT=ReallySuppress

Hit Enter to run and install the Data Scheduler service.

More Information

If the above instructions fail, review theWebtrends.DataSchedulerService.InstallLog.There will be an entry about 45 linesdown starting with “The database connection string is:”Confirm whether or not the port used is 3306. If so, that means a remnant of an old installation is present in the registry which will require removing Webtrends, running the Webtrends cleaner, then reinstalling to fix this.