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Export rights for scheduled jobs in Microsoft formats

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Cause

If a domain user was not specified during Webtrends installation, you may not be able to schedule Microsoft Word reports with the default installation. This is because the Webtrends Scheduler Agent service needs to launch Microsoft Word in order to run macros to complete its tasks, and it cannot do this if it only has default system user privileges. This problem does not affect batch exports or Webtrends On Demand exports; in those cases Word is being launched by the user, not the system account. If you want to run scheduled exports to Microsoft Word format, you must configure the Webtrends Scheduler Agent to log on as an account that has access rights to those drives. For most users, configuring the Scheduler agent to log on as a domain user is the simplest way to make sure the agent has the appropriate rights. Specifying a domain user while installing Webtrends usually provides the appropriate user rights configuration. If you still have problems accessing datasources or running scheduled exports, however, or if you cannot use a domain user, you should check the user rights for the Scheduler agent to make sure it has the appropriate rights as described in the following procedures.

Resolution

To configure the Scheduler Agent to log on as a domain user:
1. In Windows Control Panel, select Administrative Tools > Services.
2. Select the Webtrends Scheduler Agent service.
3. Right-click and select Properties.
4. Select the General tab and click Stop.
5. Select the Log On tab.
6. Click This account and type the domain and user name of the domain user in the text box. Use the format yourdomain\username.
7. Provide the domain user’s password and retype it to confirm.
Note: If you are using Microsoft Internet Explorer and experience trouble downloading the Report Exporter, it may be due to your security settings (found under Tools > Internet Options in most versions of Internet Explorer). For more information, contact your Webtrends administrator
8. Return to the General tab and click Start to restart the Webtrends Scheduler Agent service.
9. Click OK. The Services panel should show the domain user in the Log On As column.
To ensure that the Webtrends Scheduler agent logs on using the correct user account:
1. From the Windows Control Panel, select Administrative Tools.
2. In the Administrative Tools dialog box, select Component Services.
3. Select Services (Local) in the left pane.
4. Right-click Webtrends Scheduler Agent, and select Properties.
5. Select the Log On tab.
6. Select This account, and click Browse to select an account from the list.
7. Provide the domain user’s password and retype it to confirm.
8. Click OK.
9. Restart the Webtrends Scheduler Agent.
To ensure that the user account has the necessary rights:
1. From the Windows Control Panel, select Administrative Tools.
2. Select Local Security Policy.
3. In the left pane, expand Local Policies.
4. Select User Rights Assignment.
5. Select Act as Part of the Operating System.
6. If the account you specified in the previous procedure is not listed, click Add User or Group. Add the user account the Webtrends Scheduler Agent should use, and click OK.
7. Otherwise, click Cancel.
8. Select Log on as a Service.
9. If the account you specified in the previous procedure is not listed, click Add User or Group. Add the user account the Webtrends Scheduler Agent should use, and click OK.
10. Otherwise, click Cancel.
11. If your computer uses Microsoft Windows 2000 or Windows XP, select Log on Locally.
12. If the account you specified in the previous procedure is not listed, click Add User or Group. Add the user account the Webtrends Scheduler Agent should use, and click OK.
13. Otherwise, click Cancel.
14. Close the Local Security Settings dialog box.