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Error: opened an empty file

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Cause


The following error message similar to the following appears in the profile’s status messages:

Error: opened an empty file C:\Program Files\WebTrends\storage\config\wtm_wtx\datfiles\profiles\.wlp.

This indicates that the profile’s configuration file is empty and is usually caused by corruption. If only the configuration file is corrupted it may be possible to restore the profiles “.wlp” file with a backup.



Resolution

Open the Windows Services snap-in and stop the “Webtrends – Scheduler Agent” service.

Open Windows Explorer and navigate to the path specified in the error message. All profile configuration files are in the \profiles folder. Each profile will have one .wlp file (the current configuration) and a number of backup files which use the .bak extension.

Rename the .wlp file to .wlp.bad

Rename the most recent .bak file to .wlp to replace the current configuration.

Restart the “Webtrends – Scheduler Agent” service.

Attempt to analyze the profile. On completion of analysis, view the report data to verify everything is now working without issue.

More Information

Please see the article: http://kb.webtrends.com/Information/How-did-my-database-or-configuration-files-become-corrupted/