Products
Webtrends Analytics 8.1x
Webtrends Analytics 8.0d
Cause
This document describes how to upgrade Webtrends Analytics 8.0d to 8.1x.
Resolution
To upgrade to 8.1x the server must first be upgraded to Webtrends Analytics 8.0d (if not currently running Webtrends Analytics 8.0d), tested for stability, then upgrades to 8.1x from 8.0d.
The only upgrade path at this time to Webtrends Marketing Lab 8.1x is from Webtrends Analytics 8.0d.
To upgrade, ensure that you have backed up your entire root Webtrends installation directory prior to running the installer. During the installation process the upgrade installer will call the 8.0d uninstaller, uninstall 8.0d then install 8.1x.
Webtrends 8.1x uses Microsoft Internet Information Service (IIS) for its user interface GUI and no longer requires Apache. Also, the user interface server will not work in a 64-bit environment so it must be installed to a 32-bit environment. This means if your installation is on a Windows 2003 x64 architecture, it will not install the user interface service. This only pertains to the user interface component; the rest of the Webtrends services will install in a Windows 2003 x64 architecture.
You must install IIS with ASP.net prior to running the installer, otherwise the installation will fail if IIS. The upgrade should otherwise be fairly straight forward except that the main interface is notably improved over that of previous versions of the product.
After you have upgraded the Webtrends product and prior to viewing the main page, clear the browser’s internet cache as it can cause issues with viewing the new interface.
Some common questions customers ask about this process are as follows:
Q: Does the 8.1x upgrade process require a system reboot?
A: On Windows XP systems, you will be prompted to reboot when the installer completes successfully. Under most circumstances, you should not have to reboot on Windows 2003 Server systems, though rebooting after installation of any application is considered an industry best practice (the down side being the time required while the server restarts).
Q: Why does the installer say my license is invalid?
A: Ensure the license has current maintenance and the number of activations has not been exceeded. The wtlicman utility can generally be used to find a more specific error message.
Q: During the upgrade, the installer hangs while stopping the Apache service. How do I continue?
A: Manually stop the Apache service either by using the Windows services snap-in or, if necessary, by killing the Apache process in the Windows Task Manager. Be sure to close the Services snap-in after the service stops or installation cannot proceed.
Q: The upgrade failed and did not roll back to a working 8.0d installation. How do I recover?
A: The 8.1x installer first uninstalled the 8.0d installation; then installs the new version of the software. If the installation fails, you can re-run the 8.1 installer and it will make a clean installation, but import your data from its data backup location.
It is recommended that the the upgrade is run in a test environment prior to rolling it out to your production environment and let users get used to the look and feel of the new interface.