Products
Webtrends Analytics 8.7d
Webtrends Analytics 8.5x
Issue
During analysis, a visitor history enabled profile will return the message – “WTRS returned with an error: Error code 1”. When viewing the status log, you see one of the following line/s:
“Failed to get all function pointers in plugin”.
or
“ActiveX Plugin : Error in \Webtrends\modules\analysis\engine\8.x\XltVrBucket.dll: Unable to load Plugin Module. (Reason: Error loading type library/DLL.)“
Cause
This issue typically comes about after rolling back from a failed upgrade. This error can also indicate that the \webtrends\storage repositories have not been restored properly. When rolling back, the \storage repositories MUST be recovered from media or server backup, not from directories involved with the failed upgrade.
Resolution
1) Stop the “Webtrends – Scheduler Agent” service on all analysis enabled machines.
2) Navigate to \webtrends\modules\analysis\engine\8.x directory (x being the current version you are on: 8.5, 8.7 etc)
3) Delete the contents of this directory, leaving the file structure in place. Repeat for all analysis servers.
4) Navigate to \webtrends\storage\confiig\wtm_wtx
5) Edit the wtm_wtx.ini file, find the line that starts with: “wtplugin”
6) Verify that the line looks like the following:
a) (8.5x)wtplugin =vh.dll,ax:XltVrBucket.dll,wtt.dll
b) (8.7d)wtplugin =vh.dll,xltvrbucket.dll,wtt.dll
7) Save the file.
8) Restart the “Webtrends – Scheduler Agent” service on all analysis servers.
If the above process doesn’t completely resolve the issue, you will have to restore your installation again from a known good backup.