Products
Webtrends Analytics 9.x
Issue
While installing Webtrends 9.2, the installer will hang at a point while trying to install a UI and eventually fail 10 to 20 minutes later.
Cause
This can be caused by the product being unable to reach https://license.webtrends.com. An indication that there is a problem with this communication, will be found in the Main Application and UI server install log file, found in .\logs\install. The last line in it will be the sManifest line and be similar to the following-
1: InitClickOnce() sManifest=<?xml version=”1.0″ encoding=”utf-8″?> <asmv1:assembly xsi:schemaLocation=”urn:schemas-microsoft-com:asm.v1 assembly.adaptive.xsd” manifestVersion=”1.0″ xmlns:asmv3=”urn:schemas-microsoft-com:asm.v3″ xmlns:dsig=”http://www.w3.org/2000/09/xmldsig#” xmlns:co.v1=”urn:schemas-microsoft-com:clickonce.v1″ xmlns=”urn:schemas-microsoft-com:asm.v2″ xmlns:asmv1=”urn:schemas-microsoft-com:asm.v1″ xmlns:asmv2=”urn:schemas-microsoft-com:asm.v2″ xmlns:xrml=”urn:mpeg:mpeg21:2003:01-REL-R-NS” xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance”> <assemblyIdentity name=”MarketingLab.[[IDENTITY]].application” version=”[[VERSION]]” publicKeyToken=”e9357f3b2cdc9099″ language=”neutral” processorArchitecture=”x86″ xmlns=”urn:schemas-microsoft-com:asm.v1″ /> <description asmv2:publisher=”WebTrends” asmv2:product=”WebTrends Explore [[OPTIONAL_PRODUCT_DESC]]” xmlns=”urn:schemas-microsoft-com:asm.v1″ /> <deployment install=”true” mapFileExtensions=”true” trustURLParameters=”true”> <subscription> <update> <beforeApplicationStartup /> </update> </subscription> <deploymentProvider codebase=”[[DEPLOY_PROVIDER_URL]]/wrc/component/MarketingLab/MarketingLab.application” /> </deployment> <dependency> <dependentAssembly dependencyType=”install” codebase=”MarketingLab_[[VERSION_PATH]]\MarketingLab.exe.manifest” size=”28959″> <assemblyIdentity name=”MarketingLab.exe” version=”[[VERSION]]” publicKeyToken=”e9357f3b2cdc9099″ language=”neutral” processorArchitecture=”x86″ type=”win32″ /> <hash> <dsig:Transforms> <MSI (s) (2C:74) [15:41:52:266]: Running as a service.
Resolution
To resolve this, either
a. Open the firewall to all allow the program to communicate with license.webtrends.com
b. Correct the DNS servers that are resolving it, so it can resolve license.webtrend.com