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Data Scheduler Error – TCP Provider, error: 0 – No connection could be made because the target machine actively refused it.

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Issue

When trying to use the Data Scheduler, either by clicking on Upcoming>New, Available Files, or History, the following error occurs (also see screenshot attached to article):

“A network-related orinstance-specific error occurred while establishing a connection to SQL Server.The server was not found or was not accessible. Verify that the instance nameis correct and that SQL Server is configured to allow remote connections.(provider: TCP Provider, error: 0 – No connection could be made because thetarget machine actively refused it.)”

Cause

Navigate to the wtmaster.wt_databaseinstance table. Within this table, there is a Port column and if SQL is running on the default port of 1433, the value of this column should be NULL. The most common value is 3306 (MySQL port) and the entry needs to be updated to be NULL. If SQL is running on a different port other than the default 1433, this value should be updated to the port SQL is running on. To update this, run one of the following statements depending on how SQL is setup:

If SQL using default port 1433:
UPDATE wtMaster.dbo.wt_DatabaseInstance
SET Port=NULL;

If SQL using other than default port 1433:
UPDATE wtMaster.dbo.wt_DatabaseInstance
SET Port=Port that SQL runs on;

Example if SQL is running in 1506:

UPDATE wtMaster.dbo.wt_DatabaseInstance
SET Port=1506;


The Data Scheduler gets its connection information from this table. If information is incorrect for the port, it will not connect while the rest of the Webtrends Analytics application will.