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Why are there gaps in my report data?

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x

Cause

Within a larger reporting period, analysis of a subset of data was skipped or missed, causing gaps to appear in reports. As an example, a profile that has been analyzing data consistently for several months was unable to analyze a day of log files due to their unavailability or technical issues. Analysis continued with the next day’s log files, but since analysis has already moved past that point, Webtrends is unable to backfill the data and the reports show no data for the missed day.

In order to avoid issues like this in the future, it is necessary to guarantee the environment in which Webtrends is running has no third-party processes that could adversely affect Webtrends’ analysis. To do so, check for any running processes that could potentially lock files during analysis, such as ones related to anti-virus, backup, disk defragmentation, and indexing. If any of these processes are running during an analysis they could be locking files that Webtrends needs to use, which could lead to corruption within the database and missing days (gaps) in the reports.

Gaps may also appear in a report is if the profile is set to analyze an extensive number of different log files, from which the operating system is unable to allocate any more file handles. This can cause log files to be missed during analysis. This can, for example, occur when profiles have been set to analyze years of historical data during a single job. To resolve this issue, reduce the amount of data being processed in each cycle. For example, if analyzing a few month’s worth of data, change the Analysis Throttling setting to analyze only one month’s worth of data at a time. This can be changed under Web Analysis > Reports & Profiles > (edit profile) > Analysis > Analysis Throttling.

Resolution

The only way to fill in the gaps in the report is to restore the profile back to a point before the gap occurred, then on the next analysis the data should be present. Confirm backups of the profile have been made under Administration > System Management > Backup/Restore > Restore Backup. If none are available, another option may be to restore the entire installation from the last known good configuration by using a third-party backup utility, though this would mean all profiles would need to catch up in addition to the profile missing data. If no backups of either type are available then the only way to add the missing data to the report will be to re-analyze the profile.

Once the historical data has been analyzed the log data sources can be configured to use date macros. Date macros allow users to analyze a small set of data without having to update the data source manually.

More Information

How do I configure date macros in Webtrends?
How did my database or configuration files become corrupted?