Products
Webtrends Analytics 9.x
Webtrends Analytics 8.x
Cause
Virus scanning software, or more specifically, live virus scanning, can contribute to corruption of the Webtrends installation. A live virus scanner detects when a new file is saved to the system, or a file is changed/rewritten. When it detects this activity, it immediately attempts to scan the file before a virus has the chance to do any damage. Often times, the virus scanner needs to put a read/write lock on the file/s during the scanning process. As Webtrends performs a large number of read/writes during the analysis or data collection process, a live virus scanner attempting to scan the files being worked with can easily cause a read or write failure. This can result in incorrect data within the file/s, and can consequently corrupt the integrity of the file/s or application. This same activity can affect any other configuration file that is modified/used by Webtrends.
Resolution
As a best practice, Webtrends recommends excluding the entire Webtrends directory and sub-directories from being scanned to prevent Anti-Virus software from causing corruption. In some high security environments this is not always possible. In such cases, please use the list below to configure your Anti-Virus application.
All versions:
SmartSource Data Collectorsdcweblog
SmartSource Data Collectorsdclog
SmartSource Data Collectorsdcrealtime
SmartSource Data Collectorsdccfgdcs.cfg
SmartSource Data Collectorsdccfgwebtrendssites.lst
SmartSource Data Collectorsdcbiniislogserver.dll
Additional folders version 9.x:
SmartSource Data Collectordcapiweblog
SmartSource Data Collectordcapilog
SmartSource Data Collectordcapirealtime
SmartSource Data Collectordcapicfgmsdc_dcapimodule.cfg
SmartSource Data Collectordcapicfgwebtrendssites.lst
SmartSource Data Collectordcapibinmsdc_isapi.dll
SmartSource Data Collectordcapibinmsdc_dcapimodule.dll