Products
Webtrends Analytics 8.x
Webtrends Analytics 9.x
Cause
If it is not possible to restore a profile using Webtrends’ built-in backup feature, profiles can be restored manually if backups of the \storage folder are available. To manually restore a profile, follow the steps below.
Resolution
Note: You may want to create a full system backup before following these steps just in case something goes wrong.
1. Edit the profile(s) to be restored. Under the “General” tab, in the “Profile File Name” field, a profile displays an eleven-character string of upper- and lower-case letter and numbers. This is the profile’s globally unique identifier, or “guid” for short. Note the guids for each profile to be restored, then proceed to the next step.
1. Edit the profile(s) to be restored. Under the “General” tab, in the “Profile File Name” field, a profile displays an eleven-character string of upper- and lower-case letter and numbers. This is the profile’s globally unique identifier, or “guid” for short. Note the guids for each profile to be restored, then proceed to the next step.
2. Stop all of the Webtrends services.
3. Navigate to the following location on the Webtrends server (or node where the storage repository is located):
\Webtrends\storage\analysis\wtm_wtx\datfiles\databases\
4. Rename the folder or folders matching the profile guids to be restored, appending something like “_old” to the end.
5. Navigate to the same location in the backup:
\Webtrends\storage\analysis\wtm_wtx\datfiles\databases\
6. Copy the folders for the profiles to be restored from this location in the backup path to the storage repository in the Webtrends installation. The copy from the backup location will replace the recently renamed folder.
7. Navigate to the following location on the Webtrends server (or node where the storage repository is located):
\Webtrends\storage\reports\wtm_wtx\datfiles\databases\
8. Rename the folder or folders matching the profile guids to be restored, appending something like “_old” to the end.
9. Navigate to the same location in the backup:
\Webtrends\storage\reports\wtm_wtx\datfiles\databases\
10. Copy the folders for the profiles to be restored from this location in the backup path to the storage repository in the Webtrends installation. The copy from the backup location will replace the recently renamed folder.
If no changes to the profile configuration have been made since the time of the backup (and only analysis and report data must be restored), proceed to step 15.
11. Navigate to the following location on the Webtrends server (or node where the storage repository is located):
\Webtrends\storage\config\wtm_wtx\datfiles\profiles
12. Rename the .wlp file(s) matching the profile guid(s) to be restored, appending something like “_old” to the end.
13. Navigate to the same location in the backup:
\Webtrends\storage\config\wtm_wtx\datfiles\profiles
14. Copy the .wlp file(s) for the profile(s) to be restored from this location in the backup path to the storage repository in the Webtrends installation. The copy from the backup location will replace the recently renamed .wlp file(s).
15. Restart the Webtrends services and verify the profile has been restored to the state it was at the time the backup was made.