dcsimg

How to increase debugging verbosity of profile status logs

Products

Webtrends Analytics 8.x
Webtrends Analytics 9.x

Cause

A profile fails but review of the profile’s status messages do not indicate the cause for failure.

Resolution

In some cases, the cause for failure requires increasing the verbosity of debugging output. The default value is 5 with a maximum of 15. To change this value, follow the steps below:
1. Edit the profile and under Analysis > General (the default screen displayed when first editing the profile), make note of the value in the “Profile File Name” field. The expression will be alphanumeric and of mixed case, and is referred to as the guid.
2. Now that the profile guid has been identified, navigate to the following path:
\Webtrends\storage\config\wtm_wtx\datfiles\profiles
Locate the corresponding .wlp for the profile and open it in a text editor.
3. In the [profile] section, locate the line containing debuglevel= and change it to read as follows:
debuglevel=15
4. Save the changes and restart the “Webtrends – Scheduler Agent” service.
5. Attempt to analyze the affected profile.
6. After the job has completed, navigate to the following folder:
\storage\analysis\wtm_wtx\datfiles\statuslogs

Note: For version prior to 8.7d, the status logs are found here:
\storage\config\wtm_wtx\datfiles\statuslogs\
7. Locate the status log which corresponds to the profile and save a copy of the log for review with a Webtrends Technical Support Engineer.
It is recommended that the debugging level be decreased after the need for verbosity is no longer required.

More Information

There are only three valid values for the debuglevel entry. They are 5, 10, and 15. No other values should be used.