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How to avoid gaps in analysis after an analysis queue has stopped for data sources which use archived log data or date macros

Products

Webtrends Analytics 9.x
Webtrends Analytics 8.x
Webtrends Enterprise 7.x
Webtrends Professional 7.x
Webtrends Small Business 7.x

Cause

Log files have not been analyzed for several days due to an issue with the analysis queue or server down time, and the data source folders are archived after a very short period of time, or the data source definitions use date macros that only go back a few days for the log files. If analysis is performed prior to making additional modifications gaps will appear in report data.

Resolution

In the case of archived log files, all of the logs for the days that have not been analyzed must be manually recovered to the folder to which the data source(s) is points. Ensure the entire day’s log file for the last analyzed day is present in this folder. It is possible the entire day did not get analyzed, or the log file will be required to close visits that are near the midnight barrier. After the catch-up analysis completes the log files can once again be archived.

For data sources that use date macros, there are two options. The first is to create an additional data source for each profile that points to the same directory or directories as the original data source, but includes all of the log data going back to the last day analyzed. This data source can then be added to the profile prior to the catch-up analysis. Once analysis is up to date, the data source can be removed from the profile and then deleted from the list of data sources. The second option is to modify the current data source for each profile and add the appropriate paths to include the data going back to the last day analyzed. Once the catch-up analysis is complete, modify the data sources again to return them to their original configurations.