Products
Webtrends Analytics 8.x
Webtrends Analytics 9.x
Cause
Webtrends can be configured to look at only hits where the Authenticated Username field was populated with a user name, only hits where the field is empty and no user had logged in, or only certain users. To filter for all users or no users follow the steps below:
Resolution
1. In the Webtrends user interface, navigate to “Web Analysis > Options > Hit Filters” and select “New”.
2. Enter a name, select “Include” (to keep only hits with a user name and remove all hits with no user name) or “Exclude” (to remove all hits with a user name and keep only hits with no user name), select “Web server,” select “Include/Exclude activity based upon the following Active Hit Filter Parameters,” then select “Authenticated Username (Web Server).”
3. Click Next, and under “Authenticated Username” enter an asterisk (*), which will apply to all entries in the cs-username field.
4. Check the box for “Include/Exclude all hits from authenticated users” and save the filter.
5. Under “Web Analysis > Reports and Profiles”, edit the profile to which this will be applied, then navigate to “Advanced > Hit Filters”, check the box for the new filter and save the changes.
More Information
In order for this filter to apply to historical data, the profile must be reanalyzed. Otherwise, selecting Analyze Now or allowing scheduled analyses to take place will make it effective for report data from the point at which it had been applied.
Webtrends On Demand users must perform an Ad-Hoc analysis to apply the filter to historical data.