Products
Webtrends Analytics 8.x
Webtrends Analytics 9.0x
Cause
User interface issues can be troubleshooted by enabling Tomcat logging and debugging. The following steps outline how to enable this feature.
Resolution
1. Open the user interface and navigate to Administration > System Management > Hosts > UI Server.
2. Select “Use local settings” and check the boxes for Enable Tomcat Logging and Enable Tomcat Debugging.
3. Save the changes and restart the services when prompted.
Steps to take to enable UI debugging in if you cannot access the User Interface:
1. Open a command line window.
2. Navigate to the following directory:
\Webtrends\common\database\mysql\bin
3. Run the following command to log in to the MySQL database:
mysql -u -p
4. Run the following command: use wt_sched
5. If the host is configured to use global settings (default), update the global role setting using the following query:
UPDATE wt_ServiceRoleSetting SET value = ‘1’ WHERE SettingId = 17; UPDATE wt_ServiceRoleSetting SET value = ‘1’ WHERE SettingId = 19;
6. Restart the ‘Webtrends – User Interface’ service.
The Tomcat debug log files will be located in the following directory:
\logs\tomcatdebug_YEAR-MONTH-DAY.log