Products
Webtrends Analytics 9.x
Webtrends Analytics 8.x
Cause
Web servers do their best to log records in time sequence, however there are always going to be records that are logged out of order. If the records are too far out of sequence, Webtrends will not analyze them as it has already analyzed the time frame for which the record falls in.
Resolution
Increase the out of order logic to account for records too far out of sequence to be sorted and processed correctly.
Webtrends has the ability to sort log file entries that are not sequentially ordered up to a certain point. The setting to adjust the “Out of Order” logic, is found either in the profile or globally.
For a single profile:
1) Edit the Profile
2) Go to Analysis>Resource Control
Options:
Webtrends has the ability to sort log file entries that are not sequentially ordered up to a certain point. The setting to adjust the “Out of Order” logic, is found either in the profile or globally.
For a single profile:
1) Edit the Profile
2) Go to Analysis>Resource Control
Options:
- Use the system default settings
- Disable out of order logic for this profile (log files are already ordered)
- Sort out of order records by:
Globally:
Navigate to “Web Analysis”>Options>Analysis and select the “Resource Control”
Options:
Navigate to “Web Analysis”>Options>Analysis and select the “Resource Control”
Options:
- Disable out of order logic (log files are already ordered)
- Sort records that are out of order by:
By default, the out of order logic is set to 3 seconds and can be increased to account for records that are beyond 3 seconds out of order. Increasing the out of order logic in seconds, will also increase resource usage when a profile is running along with the length of time the profile processes if records are extremely out of order.
More Information
If you find that this is causing the profile to run too long and not complete in the time needed to produce reports, we recommend having the log files sorted prior to being analyzed by Webtrends.