Products
SmartSource Data Collector
Cause
TheSmartSource Data Collector (SDC) is configured to rotate logs on a regular basis. Although the dcs.cfg file has Hosted Model set to “True”, the logs rotate at irregular intervals.
Resolution
This may be caused by the environment or the web server on which the SDC is running. The SDC writes out logs whenever the web site is stopped or starts, whenever the SmartSource Data Collector’s IIS application pool is restarted, or any other time something causes the web server become unavailable.
One of the most common reasons is because of the default IIS application pool settings. In IIS, navigate to Application Pools and right click on the SmartSource Data Collector, then select Properties. Make sure nothing is checked on the Recycling tab or the Performance tab. Options on both of these will cause the application pool to restart either on a regular basis or when it has been idle a certain number of minutes.