KnowledgeBase - DX API Keymetrics request doesn't work with 9.3b
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DX API Keymetrics request doesn't work with 9.3b

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Webtrends 9.3b
Symptoms
Keymetrics requests (eg https://myDomain.com/v2_0/ReportService/keymetrics/z7iUDbTRxI6/?start_period=2009m10d15&end_period=2009m10d16) returns "There was an error handling your request"
Cause
RDA Integrated and RDA Stand Alone were removed from the installer as Insight was deprecated.
Workaround
On the box hosting the DX API:

1. Open a CMD prompt

2. Navigate to C:\Windows\SysWOW64\

3. Run the following (make sure to update server name and paths if they are different):
msiexec.exe /i "<path to 9.3b installer folder>\Webtrends OnPremises Installer\msi\WebTrends RDA Updater (Engine Integrated).msi" /qb! /l*v "<path to Webtrends installation folder on DX API machine>\logs\install\RDA Integrated <current date>.log" IS_SQLSERVER_SERVER="<server name>\wtsystemdb" IS_SQLSERVER_DATABASE="wtMaster" REBOOT=ReallySuppress

4. Run the following (make sure to update paths if they are different):
msiexec.exe /i "<path to 9.3b installer folder>\Webtrends OnPremises Installer\msi\WebTrends RDA Updater (Stand Alone).msi" /qb! /l*v "<path to Webtrends installation folder on DX API machine>\logs\install\RDA Stand Alone <current date>.log" INSTALLDIR="<path to Webtrends installation folder on DX API machine (eg C:\Program Files (x86)\Webtrends\)>" REBOOT=ReallySuppress

5. Run analysis on a profile

6. Open a file explorer. Navigate to \storage\RDA and verify that the file meta_db has file size.

7. Try running a Keymetrics API call on the profile that you analyzed.
 
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