Products
Webtrends Analytics 8.1
Webtrends Analytics 8.0
Webtrends Analytics Legacy
Webtrends Analytics 8.0
Webtrends Analytics Legacy
Cause
The following steps describe how to back up, uninstall, reinstall and restore a Webtrends Analytics installation which uses MySQL as the system database.
Three folders comprise the entirety of user-specific data in the Webtrends installation. The process detailed below will ensure profile configurations, analyzed report data and related settings will remain intact as they are migrated out of the existing installation into the new one.
Three folders comprise the entirety of user-specific data in the Webtrends installation. The process detailed below will ensure profile configurations, analyzed report data and related settings will remain intact as they are migrated out of the existing installation into the new one.
Resolution
Backing up and uninstalling Webtrends
Webtrends must be reinstalled to the same path in which it is currently installed. Make note of the path in case it does not conform to the default location. In addition, copy the license keys from the Licensing section of the user interface into a text file in the event the product must be relicensed.
Ensure no analysis or other tasks are currently running. In the Webtrends user interface, under Scheduler > Job Queue, confirm all jobs have been canceled or allow running jobs to finish before continuing.
1. Stop all of the Webtrends services in the following order:
“Webtrends – Scheduler Agent”
“Webtrends – User Interface”
“Webtrends – Report Cache Server”
“Webtrends – Express Data Mover”
“Webtrends – Express Analysis Engine”
“Webtrends – GeoTrends”
“Webtrends – Email Notification Service”
“Webtrends – System Monitor”
“Webtrends – MySQL”
2. Back up the following folders to a temporary storage location:
\Webtrends\common\database\mysql\data\wtmaster
\Webtrends\common\database\mysql\data\wt_sched
\Webtrends\storage
3. Uninstall Webtrends using the Add/Remove programs option in Windows Control Panel.
Reinstalling Webtrends
1. Install Webtrends using the original installation path.
2. Stop the Webtrends services in the following order:
“Webtrends – Scheduler Agent”
“Webtrends – User Interface”
“Webtrends – Report Cache Server”
“Webtrends – Express Data Mover”
“Webtrends – Express Analysis Engine”
“Webtrends – GeoTrends”
“Webtrends – Email Notification Service”
“Webtrends – System Monitor”
“Webtrends – MySQL”
3. Rename the following folders:
\Webtrends\common\database\mysql\data\wtmaster
\Webtrends\common\database\mysql\data\wt_sched
\Webtrends\storage
rename to
\Webtrends\common\database\mysql\data\wtmaster-clean
\Webtrends\common\database\mysql\data\wt_sched-clean
\Webtrends\storage-clean
4. Copy the original folders from the backup location into the new Webtrends installation (thereby replacing the ones that were renamed).
5. Start the Webtrends services in the following order:
“Webtrends – MySQL”
“Webtrends – System Monitor”
“Webtrends – Email Notification Service”
“Webtrends – GeoTrends”
“Webtrends – Express Analysis Engine”
“Webtrends – Express Data Mover”
“Webtrends – Report Cache Server”
“Webtrends – User Interface”
“Webtrends – Scheduler Agent”
6. Log into the Webtrends user interface and confirm report data is intact and everything is working as expected.
Webtrends must be reinstalled to the same path in which it is currently installed. Make note of the path in case it does not conform to the default location. In addition, copy the license keys from the Licensing section of the user interface into a text file in the event the product must be relicensed.
Ensure no analysis or other tasks are currently running. In the Webtrends user interface, under Scheduler > Job Queue, confirm all jobs have been canceled or allow running jobs to finish before continuing.
1. Stop all of the Webtrends services in the following order:
“Webtrends – Scheduler Agent”
“Webtrends – User Interface”
“Webtrends – Report Cache Server”
“Webtrends – Express Data Mover”
“Webtrends – Express Analysis Engine”
“Webtrends – GeoTrends”
“Webtrends – Email Notification Service”
“Webtrends – System Monitor”
“Webtrends – MySQL”
2. Back up the following folders to a temporary storage location:
\Webtrends\common\database\mysql\data\wtmaster
\Webtrends\common\database\mysql\data\wt_sched
\Webtrends\storage
3. Uninstall Webtrends using the Add/Remove programs option in Windows Control Panel.
Reinstalling Webtrends
1. Install Webtrends using the original installation path.
2. Stop the Webtrends services in the following order:
“Webtrends – Scheduler Agent”
“Webtrends – User Interface”
“Webtrends – Report Cache Server”
“Webtrends – Express Data Mover”
“Webtrends – Express Analysis Engine”
“Webtrends – GeoTrends”
“Webtrends – Email Notification Service”
“Webtrends – System Monitor”
“Webtrends – MySQL”
3. Rename the following folders:
\Webtrends\common\database\mysql\data\wtmaster
\Webtrends\common\database\mysql\data\wt_sched
\Webtrends\storage
rename to
\Webtrends\common\database\mysql\data\wtmaster-clean
\Webtrends\common\database\mysql\data\wt_sched-clean
\Webtrends\storage-clean
4. Copy the original folders from the backup location into the new Webtrends installation (thereby replacing the ones that were renamed).
5. Start the Webtrends services in the following order:
“Webtrends – MySQL”
“Webtrends – System Monitor”
“Webtrends – Email Notification Service”
“Webtrends – GeoTrends”
“Webtrends – Express Analysis Engine”
“Webtrends – Express Data Mover”
“Webtrends – Report Cache Server”
“Webtrends – User Interface”
“Webtrends – Scheduler Agent”
6. Log into the Webtrends user interface and confirm report data is intact and everything is working as expected.