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Upgrading to 8.5x fails when installing MS SQL Express database (prior to conversion)

Products

Webtrends Analytics 8.5x
Webtrends Analytics 8.1a
Webtrends Analytics 8.0d

Issue

When upgrading to Webtrends 8.5x the upgrade fails and the installation log (setup.log) indicates this was due to the MS SQL Express component failing. This failure happens prior to any database conversion attempts.

Cause

This can happen on an HP server running the HP Insight application suite. Stop and disable the HP Insight services using the Windows services control panel, and attempt the upgrade again.

Another possible cause is Windows security policies. Server environments that enforce long passwords for database applications will fail during the creation of the temporary “sa” account in MS SQL Express. This account is only used during the installation and is disabled afterwards. If a security policy is in place that requires passwords longer than 10 characters, the installation of SQL Express will fail because the “sa” account can’t be created.The only currentpossible solutionfor this is to remove the machine from the network, and then temporarily remove the security policy, install the product, replace the security policy, and then re-add the machine to the network.
One more possible cause of failure is a database component failure. That is, one of the associated helper applications fails to properly install, resulting in a failed database installation. This can be verified by checking the MS SQL Setup Bootstrap log. This type of failure will usually display an error message directing you to this log, which should be located in a path similar to the following:

\Program Files\Microsoft SQL Server\90\Setup Bootstrap\LOG\summary.txt

In this log you can see a list of all of the individual components that Webtrends installs. There are msi files for several of these components in the extracted Webtrends installer folder. You can install these components manually prior to running the setup.exe for Webtrends and resolve automated install failures with any of these components in this way.

For further assistance with this process, call Webtrends Technical Support at (503) 223-3023.